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Get All Your Details Done in Revit 
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 Course Summary: 
Who said you can’t produce details in Revit? This class will prove those people wrong! We will look at creating 
details directly in Revit and how to use details in Revit that were originally created in AutoCAD or ADT.  Then 
you’ll learn how to add those details to a set of Revit documents so that Revit can automatically manage all of 
the callouts and detail references to create a completed coordinated set of construction documents. We’ll also 
learn how to put the details in the details, with a look at Revit’s dimensioning and keynoting capabilities. 

 

   

 Instructor: 
David has more than 20 years of hands-on experience with AutoCAD as a user, developer, author and 
consultant. He is an applications engineer with The PPI Group, a contributing editor to Desktop Engineering 
magazine, the former publisher and editor-in-chief of CADCAMNet and Engineering Automation Report, the 
former senior editor of CADalyst magazine, and the author of more than a dozen books on AutoCAD. A 
licensed architect, David was also one of the earliest AutoCAD third-party software developers, creating 
numerous AutoCAD add-on programs. As an industry consultant, David has worked with many companies 
including Autodesk. He teaches college-level AutoCAD courses and is always a popular presenter at Autodesk 
University. 
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Introduction 
Revit is a powerful design and documentation system providing a complete environment in which to 
create construction documents. With Revit, as you work you actually create a complete information 
model of the building in three-dimensions. Plans, elevations, and sections are just different ways of 
viewing the building information model. Revit makes it easy to place these views onto drawing sheets, 
which constitute just another way of organizing and viewing building information. 

Construction documents also normally include many two-dimensional details, and Revit provides all 
the tools you need to create these details. You can detail directly in a view of the building information 
model, using ready-made 2D detail components such as dimensional lumber, flashing, plywood, and 
metal studs, or create your own components. You can also import existing details from other CAD 
programs, and even incorporate hand-drawn details, photographs, and other images that you might 
want to include in the final construction document set. 

About Callouts 
In order to create a detail, you use callout views to get a separate view of a portion of 
an existing view. You can use the Section, Elevation, or Callout tools to create a callout 
view, which can be made in a plan, section, detail, or elevation view to create a more 
detailed view of part of the building model from that of the parent view. The area that 
the callout defines in the view is the callout bubble. The callout bubble is connected to 
a symbol called the callout head, which displays the detail number and sheet number 
when the callout is placed on a sheet. The callout bubble and callout head are 
connected by a leader line. Together the callout bubble, callout head and leader are 
referred to as the callout tag.  

 
When you create a callout, a new view called a callout view is created. A callout view is a separate, 
large-scaled view of a defined area in a parent view. If the parent view is deleted, the callout view is 
also deleted. 
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There are two types of callout views: 

Callout in Parent View – If you want the callout to share the 
properties of the parent view, you create the callout view using the 
same view as the parent. For example, if you create a callout in a 
floor plan view using a Floor Plan view type, the callout view is 
displayed under Floor Plans in the Project Browser. 

Callout in Detail View – If you create a callout in any plan, section, 
or elevation view using the Detail View type, the callout view is 
displayed under Detail Views in the Project Browser. Detail Views 
have the properties of being hidden in the parent view at certain 
scales, and can also be made visible in intersecting views. 

Clip Planes 

The boundaries of the callout bubble define clip planes for the extents of the callout view. You can 
resize the clip planes to resize the view by selecting the callout bubble and dragging the control dots. 
Resizing the callout view crop region resizes the callout bubble in the parent view. 

Reference Callouts 

Reference callouts reference an existing view and do 
not create a new view. For example, you may create a 
detail view for the coping at a parapet. The original 
callout appears in the view in which you create it. But 
when that same condition exists in other parts of the building, you may want to add additional 
callouts that reference the same detail. To accommodate these situations, you create a reference 
callout by selecting Reference Other View on the Options bar and then selecting the existing view 
from the adjacent drop-down. 

Drafting Views 

Drafting views are 2D views that you create from scratch using Revit’s drafting tools or import from 
drawings that were originally created in AutoCAD or some other CAD program. Once created or 
imported, you can use reference callouts to refer to these views. 
 

Creating a Detail from a Building Model 
To create a detail from the building model, you first define the view in which you want to create a 
detail. For example, to create a section detail, you first define the detail view by creating a callout 
view within a section view. In the callout view, you trace over the building model geometry, add 
detail components, and then complete the detail by adding break lines and text notes. 
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Creating a Callout View 

As explained, a callout view is a view of an area in an existing view that you need to show at a larger 
scale. You can create a callout view in a plan, section, elevation, or detail view. In this case, we’ll 
create a callout view in a section view to show the foundation detail at a larger scale. To do this, we’ll 
open the section view and use the Callout tool on the View tab of the Design bar to add a new callout 
view. (Remember that the section view already has a direct connection to the section tag. For 
example, if you flip the direction of the section tag, the section view updates.) 

 
1. On the View tab of the Design bar, click Callout. 
2. On the Options bar, select Detail View: Detail View 1 from the Type Selector drop-down. 
3. On the Options bar, select the desired scale from the Scale drop down. (Remember that you 

can always change the scale of the view later.) 
4. In the section view, place the callout by specifying the opposite corners of a rectangle to 

define the extents of the callout. 

Revit immediately shows the callout tag in 
the section view and adds the view to the 
Detail Views branch in the Project Browser. 
You can then resize the callout and/or 
reposition the callout head by selecting the 
Modify tool, clicking on the callout border, 
and then adjusting the control dots. You can 
display the new detail view by double-clicking 
on either the callout head in the section view or the new detail view in the Project Browser. You can 
change the name of the new detail view to something more meaningful (such as “Foundation Detail”) 
by renaming it in the Project Browser or by displaying the Element Properties dialog for the view and 
then changing its view name under Identity Data. 

 

Autodesk User Group International 

www.AUGI.com 
Copyright © AUGI CAD Camp 2007 

 

4



 
Detailing the View 

Once you have created the detail view, you use tools on the Drafting tab of the Design bar to add the 
additional detail in 2D, working over the top of the enlarged view of the model. The list below 
describes the tools on the Drafting tab that you will likely use most often. 

Detail Lines – lets you draw detail line work (lines, arcs, circles, etc.) by selecting the 
desired line type from the Options bar. Detail lines have all the same options as model 
lines, except that they only appear in the view in which they are created. 

Detail Group – lets you insert a detail group into the current view. A detail group 
contains a named collection of detail (view-specific) elements. 

Detail Component – inserts a 2D detail component, a pre-drawn component from a 
2D family that represents a common element, such as a piece of wood blocking, an 
anchor bolt, or a steel shape. Revit includes a library of standard detail components and 
you can easily create and add your own detail components to the library. 

Masking Region – lets you add a white or opaque filled region to hide other elements. 
You can set the edge lines of the masking region to be visible or invisible. 

Repeating Detail – inserts a linear array of other detail components. For example, to 
show brick coursing, you can create a repeating detail that repeats a single brick and 
mortar joint. Then, you sketch a path and the path is filled with the repeating detail. 

Insulation – lets you add batt insulation in detail views. 

Filled Region – lets you define the boundary of a two-dimensional region that is then 
filled with a fill pattern (similar to a hatch pattern in AutoCAD).  

 

Note that if you are running Revit on a system with a relatively low 
display resolution (such as 1024x768) or in a reduced window, you may 
not be able to see all of the tools on the Drafting tab. In that case, click 
on More Tools > at the bottom of the tab to display the additional tools. 

Here are the steps I used to add a filled region representing the earth fill 
outside the foundation: 

1. On the Drafting tab of the Design Bar, click Filled Region. 
2. On the Sketch tab of the Design Bar, click Lines. 
3. In the Type Selector, select Wide Lines. 
4. On the Options Bar, select Chain and click . 
5. Trace the region representing the sloped grade. 
6. On the Design Bar, click Region Properties. 
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7. In the Element Properties dialog box, click Edit/New. 
8. In the Type Properties dialog box, click Duplicate. 
9. In the Name dialog, enter Earth for the Name, and click OK.  
10. In the Type Properties dialog, click  in the Fill Pattern 

Value field. 
11. In the Fill Patterns dialog, under Name and Pattern, select 

EARTH.  
12. Click OK three times. 
13. On the Design Bar, click Modify and then select all but the 

top sloping line. 
14. In the Type Selector, select <Invisible lines>. 
15. On the Design Bar, click Finish Sketch to complete the filled 

region. 

Next, we’ll add lumber components to the detail. If the components you want to add have not yet 
been loaded into the project, you must first load the necessary components and then place them into 
the detail. 

1. On the Design Bar, click Detail Component. 
2. On the Options Bar, click . 
3. In the Open dialog, navigate to the location of the component you want to load (in this case, 

Imperial Library\Detail Components\Div 06-Wood and Plastic\06100-Rough Carpentry\06110-
Wood Framing\Nominal Cut Lumber-Section.rfa) and click Open. (Note that Revit’s 2D detail 
library is arranged by CSI division.) 

4. In the Type Selector, select the desired size (such as Dimension Lumber Section: 2x10). 
5. Place the component into the detail. You can press the Spacebar to rotate the lumber section 

counter-clockwise. 

Even though you are adding two-dimensional components and sketching in 2D, 
you can take advantage of the parametric nature of Revit to ensure that the 2D 
detail continues to follow the 3D building model. For example, after adding the 
wood blocking, you can use the Align command to lock the blocking into 
alignment with the exterior face of the wall, the top of the footing, and so on. If 
the model subsequently changes, the detail components will follow those changes. 

Use caution when employing this technique, however, since each time you lock a 
padlock icon, you create a constraint that might prevent a future change. Sometimes the extra effort 
to align and lock detail components can outweigh the benefit of having them locked. If you anticipate 
that the changes will be minor, it may be easier not to create these constraints. 
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Continue loading and placing additional detail 
components to complete the detail. Note that 
some detail components, such as wallboard and 
plywood, are linear components. After loading the 
component, you can adjust its length by selecting 
the component (using the Modify tool) and then 
dragging its grip handles. 

To create repeating components, such as brick veneer or lap siding, add a repeating detail. For 
example, here’s how I added the exterior lap siding: 

1. On the Design bar, click Repeating Detail. 
2. On the Options bar, click the Element Properties button. 
3. In the Element Properties dialog, click Edit/New. 
4. In the Type Properties dialog, click Duplicate. 
5. In the Name dialog, enter Lap Siding and click OK. 
6. In the Type Properties dialog, under Pattern, click in the Detail 

field and select Lap Siding from the drop-down. (Note that this 
detail component must already be loaded into the project.) 

7. In the Type Properties dialog, select the Inside check box (this 
means that you’ll place the repeating detail by drawing the inside 
or back side of the siding, which corresponds to the exterior face 
of the sheathing that has already been drawn in the detail view), 
and then click OK two times to close the dialog boxes. 

8. In the detail view, click on the bottom outside corner of the 
plywood sheathing and then click somewhere beyond the top. 
(Note that if you simply click at the top of the sheathing, Revit 
may not draw the final element of the repeating pattern. If you 
click beyond the top of the detail, the final element will be drawn and then cut off by the clip 
boundary.) 

9. As a final step, you will probably want to use the Detail Line tool to add a short length of wide 
line at the bottom of the lap siding, since Revit does not draw this using a wide line. 

You can add batt insulation using the Insulation tool. This tool is somewhat similar to drawing a 
detail line, except that instead of adding a simple line, Revit draws batt insulation. You simply specify 
the width of the insulation, the position used to locate the insulation in reference to the line you 
sketch (center, near side, or far side), and if needed an offset distance from that reference line. 
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You can also add break lines to the detail. Break lines are another type of detail component. The 
break line masks portions of the detail. To add a break line: 

1. On the Design Bar, click Detail Component. 
2. In the Type Selector, select Break Line. 
3. Place the break line in the detail view. It may be necessary to rotate the break line so that it 

masks the detail appropriately. You can also resize the break line and/or adjust the crop 
boundary grips so that the detail appears as desired. 

 
4. Select View > View Properties to display the Element Properties dialog for the detail view, and 

then turn off the crop region so that it is no longer visible in the detail view.  

The final step is to add annotations to the detail. While you can do this by using the Text tool on the 
Drafting tab of the Design bar, it’s more efficient to label detail components using keynotes. We’ll 
cover keynotes in the next section. 

Before moving on, there are a few other commands that are often useful when creating detail views. 
These three commands are located on the Tools toolbar. 

Show Hidden Line /Remove Hidden Line  – When a filled region or other detail component 
conceals another component or model element, it is sometimes desirable to have the edges of the 
concealed element show through as a hidden line. The Show Hidden Line command creates this 
condition for you, while the Remove Hidden Line command reverses its effects. 

Edit Cut Profile  – This command enables you to change the shape of elements 
that are cut in a view, such as roofs, floors, walls, and layers of compound structures. 
The command is available in plans, reflected ceiling plans, and section views. Changes 
made to the profile are view-specific; that is, the changes you make won’t affect any 
other views. This is a useful way to show something like a key between the bottom of a 
foundation wall and the top of a footing that would otherwise be unnecessary to model. 
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Changing the Component Order and Visibility Settings in Detail Views 

Within a detail view, you can arrange the order in which components display. A detail component can 
display in front or in back of all other components, or can display in front of or in back of specific 
components. 

 
This is controlled by selecting the component and then clicking on one of the four buttons that 
appear on the Option Bar: 

 

Keynoting 
Although you can add annotations to detail views using the Text tool, when it comes time to label the 
components in a detail, it is much more efficient to use keynotes. Keynoting in Revit uses a pre-
defined list of notes. The notes are organized in a keyed list defined in a separate file. The keynoting 
data provided in Revit is based on the 1995 CSI Master Format system, which uses 16 divisions to 
organize construction processes and materials and uses a tab-delimited series of keys matched to 
descriptive labels. You don’t have to actually utilize the keys in order to use the keynoting 
functionality to label your drawings. Revit can add either the keys or the descriptive labels. 

Revit’s keynote file is stored in an ASCII text file (RevitKeynotes_Imperial.txt) saved in the Imperial 
Library folder. You can use this list as is, edit it, or create your own. Creating your own or editing the 
supplied keynote file is quite easy. The exact method is described in the online Help. 

Keynote Settings 

Before you can use keynoting in a project, you must first load a keynote file. To do so: 
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1. From the menu, choose Settings > Keynoting. 
2. In the Keynoting Settings dialog, click Browse, locate the 

keynote file, and then click OK. 

Note that Revit can use one of two different keynote numbering 
methods. If you select By Keynote, Revit uses the predefined key. If 
you choose By Sheet, Revit numbers the keynotes according to the 
order in which they are added to the view, but does not display the 
number in the tag until the view is placed on a sheet. If you use 
keynote text rather than keys, this setting has no effect. 

Keynote Tags 

If a keynote tag family has not yet been loaded into your project, 
you must also tell Revit which one to use before you can place a 
keynote for the first time. The keynote tag family controls the 
appearance of the keynote. Again, Revit comes with predefined 
keynote tag families. You must simply load the one you want to use. If Revit displays an alert telling 
you that no keynote family is loaded in the project and asking if you want to load one, click Yes, 
browse to the Annotations folder, select the keynote tag family (Keynote Tag.rfa), and click Open. 

Types of Keynotes 

There are three types of keynotes: 

Element – annotates building elements. The tag reads the keynote assigned to the element in the 
model, such as the keynote assigned to a wall or door, not the individual layers or components of the 
wall or door. 

Material – annotates building materials. The tag reads the keynote assigned to the material, such as 
the layers of a wall or the components of a door. 

User – annotates user-defined components. This option always displays a Keynotes dialog so you 
can select the keynote you want to assign, thus overriding any predefined keynote. Since it is an 
override, it will not update if you later modify the type or material of the selected element. 

To add an element keynote to your detail view: 
1. On the Drafting tab of the Design bar, click Keynote > Element. 
2. On the Options bar, choose the type of keynote tag you wish to use from the type selector: 

• Keynote Tag: Keynote Number shows the keynote number in the drawing 
• Keynote Tag: Keynote Number – Boxed shows the keynote number with a box around it 
• Keynote Tag: Keynote Text shows the keynote text in the drawing 
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3. On the Options bar, select the keynote tag orientation (horizontal or vertical), and select the 

Leader check box to show or hide the keynote tag leader. 
4. Click the relevant element to identify which element to tag. An arrowhead appears at this 

location. 
5. Click the second point of the first segment for the leader. 
6. Click the final point for the end of the second segment of the leader and location of the 

keynote tag. If the element already has a value assigned for the keynote, it appears 
automatically in the tag. If there is no keynote yet assigned, the Keynotes dialog opens so you 
can select the keynote value. 

 
You can pre-assign keynotes to elements or materials in the Type Properties dialog. To do so, under 
Identity Data, click  in the Keynote field to display the Keynotes dialog, select the keynote, and click OK. 

Tip: You cannot add keynotes to a repeating detail. To work around this, stop repeating details one 
element short of the desired length and then place a single instance of the repeated component so 
that you can keynote the component in the detail view. 

The appearance of keynotes can be changed by selecting a different type of keynote from the Type 
Selector (such as keynote numbers or keynote text). 
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To add the detail view to your construction documents, you place it onto a sheet. 

 
To create a keynote legend, from the View menu, choose New > Keynote Legend. You can then 
place keynote legends on sheets containing keynoted details. You can also filter keynotes so that 
keynote legends display only those keynotes that are visible in views on the sheet on which the 
legend is placed. 
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Creating a Drafted Detail 
Drafted details are created in drafting views and are not directly based on building model geometry. 
These details do not update with changes to the building model, as there is no parametric linkage to 
any building model components. 

You can create drafted details using the drafting tools in Revit or by importing details from an 
existing detail library. After you create a drafting view, you can reference it within the model and 
place it on a sheet. 

Creating a Detail in a Drafting View 

First, we’ll create a drafting view that is not associated with a building model: 
1. Select View > New > Drafting View. 
2. In the New Drafting View dialog, enter the detail name and scale. 
3. Click OK to create the new drafting view. 

 
Next, we’ll create a new detail in the drafting view. You can use any of Revit’s drafting tools to create 
the detail. For example, you can begin by sketching the detail using Detail Lines, then apply 
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parametric dimensions using the Dimension tool, and add components and filled regions as needed to 
create the detail. When you complete the detail, you can place it onto a sheet. 

 
Creating a Reference Callout 

Once the detail has been placed on a sheet, you can easily add a reference callout to the detail. 
1. On the View tab of the Design Bar, click Callout. 
2. On the Options Bar, select Reference other view, and select the detail you want to reference. 

 
3. Add the callout to the drawing by dragging a rectangular callout bubble over the drawing in 

the appropriate position. After placing the callout, you can use the grips to change its size 
and/or reposition the callout head. 
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Importing Details into a Drafting View 
Many firms have already created libraries of standard details using other CAD programs, and many 
building component manufacturers make details of their products readily available as AutoCAD 
drawing files. Rather than recreating these details in Revit, you can add existing details to a drafting 
view to create a drafted detail. 

Revit enables you to import vector data from other CAD programs in DWG, DXF, and DGN format. 
When you import a file into Revit, you are importing all the elements, such as blocks and xrefs, from 
the drawing. They are all contained inside a Revit element called an import symbol. You can explode 
(disassemble) the import symbol into its next highest level elements; nested import symbols. This is a 
partial explode. A partial explode yields more import symbols that in turn can be exploded into either 
elements or other import symbols. This is analogous to exploding in AutoCAD with nested xrefs and 
blocks. 

You can also explode the import symbol immediately into Revit text, curves, lines, and filled regions. 
This is a full explode. 

When you link rather than import, Revit creates a link to the external file. If the external file 
subsequently changes, Revit automatically updates the link the next time you open the Revit project. 
Linked files cannot be exploded. After importing or linking to the external file, you can use Revit tools 
to trace over the geometry and/or draw additional geometry. Revit can snap to the imported/linked 
geometry. 

Importing a Detail into a Drafting View 

To import an existing CAD file into a drafting view, after creating a new drafting view: 
1. On the File menu, click Import/Link > CAD Formats. 
2. In the Import/Link dialog, select the drawing you want to import, and adjust the import 

options as needed (for example, you may only want to import visible layers, preserve the 
original colors, and control the positioning of the imported geometry). Then click Open. You 
may need to zoom to fit in order to see the imported detail. 

 

 

Autodesk User Group International 

www.AUGI.com 
Copyright © AUGI CAD Camp 2007 

 

15



 
3. On the Design Bar, click Modify and then select the detail. 
4. Right-click and then click Full Explode. 
5. If an error dialog box displays, click Delete Element(s). 

The lines of the detail are converted to detail lines and the text within the detail is converted to Revit 
text. If you specified that original colors be preserved, the text retains the original DWG layer color. 
You can subsequently change the color, if necessary. 

If the detail you import lacks leaders, you can add them in Revit. 
1. On the Design Bar, click Modify, and then select the text note. 

2. On the Options Bar, click one of the Add leader buttons ( ). A leader is 
immediately added to the text note. 

3. Select and move the leader grips to position the leader as appropriate. 

 
After completing the detail, you can place it onto a sheet and then create reference callouts as you 
learned previously. 

Linking a Detail into a Drafting View 

Linking a detail is similar to importing, the only major difference being that you can’t subsequently 
modify the imported vectors. In addition, if the external drawing subsequently changes, those 
changes will be reflected in Revit the next time you load the project. 

In this example, we’ve created a typical window head detail depicting a double-hung window in a 
wall consisting of brick veneer on 2x4 wood studs. While Revit does a decent job of roughing out this 

 

Autodesk User Group International 

www.AUGI.com 
Copyright © AUGI CAD Camp 2007 

 

16



 
detail, what we want to do is replace the Revit window with a Pella detail, which we previously 
downloaded from the Pella website and saved as an AutoCAD drawing file. 

After creating a new drafting view by placing a callout around the window head on a section view, we 
use the Import/Link dialog box to create a link to the Pella detail. After linking the detail: 

1. Move the linked vectors to the foreground and change the view properties so that the Revit 
model displays as an underlay. 

2. Use the Align command to position it within the new detail view. 
3. Use Revit drafting tools to add the additional components (wood framing, brick, gypsum board, 

wood trim, etc.). 
4. Add dimensions and keynotes, as needed. 

When you complete the detail, change the view properties so that the Revit model is no longer 
displayed. You can then place the detail onto a sheet as you would any other detail. 

 
The choice to import or link really depends on whether you expect the imported geometry to change 
in the future. If you import the geometry and the source file subsequently changes, the changes will 
not be reflected in Revit. If you link to the source file, subsequent changes will be reflected in Revit. 
But imported geometry can be exploded and then modified in Revit whereas linked geometry cannot 
be modified in Revit. You also have to consider the management of the linked geometry. Imported 
geometry becomes part of the Revit project. Linked files must be managed much the same as 
external references in AutoCAD. 
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Saving and Reusing Views 
You can save drafting views that you create in a building model as separate files so that you can 
reuse them in other projects. To do so, after creating the view, choose Save to Library > Save Views 
from the File menu. In the Save Views dialog, select the view you want to save, click OK, and then 
specify the file name and folder in which you want to save the file. (Note that you can also save a 
drafting view to an external file by right-clicking on the view in the Project Browser and choosing the 
Save to New File option in the shortcut menu.) 

You can reuse an existing view by importing it into the current project. You do this by using the 
Insert from File > Views command on the File menu. Only drafting views that do not contain model 
views may be transferred between existing projects. 

Creating and Saving Detail Components 
When you create callout views or detail views, there may be times when there is no appropriate 
detail component in Revit’s library and you need to create a new detail component. You can easily 
convert any detail lines you create into a detail component. 

1. After you’ve drawn the new detail component using detail lines, select those detail lines and 
then copy them to the clipboard. 

2. In the File menu, select New > Family. Select Detail Component Line Based as the template.  
3. From the Edit menu, select Paste from Clipboard. 
4. Click to place the line work. 
5. From the File menu, click Save As, navigate to the appropriate detail library folder, enter a 

name for the new detail component, and click Save. 

Conclusion 
Revit really does provide all the tools you need to create complete, well coordinated construction 
documents, including details that can be created from scratch within Revit or reused from other CAD 
programs such as AutoCAD and MicroStation. And with Revit, you don’t have to worry about 
coordinating construction documents. Revit will keep track of all of your details and callouts, insuring 
that your drawings are always up to date. 
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