Keep It Inside AutoCAD®: Data Extraction Direct to AutoCAD® Tables

David Cohn

GD401-1P

Do you need to create room finish schedules, parts lists, and bills of materials? For years, AutoCAD users have been creating tables for use as parts lists, bills of materials, schedules, and so on, by either laboriously creating them manually or extracting attribute data to an external file and then importing it back into AutoCAD. But this is no longer necessary. Learn how to use new tools in AutoCAD to extract attribute data directly to an AutoCAD table, and update those tables automatically when changes occur. You’ll also learn how to perform calculations on table data directly within AutoCAD and how to link AutoCAD and Excel® data into a single table that can be updated automatically. Now you can create accurate, easy-to-update data, saving you time and money.

About the Speaker:

David has more than 20 years of hands-on experience with AutoCAD as a user, developer, author and consultant. He is an independent CAD consultant, a contributing editor to Desktop Engineering magazine, the former publisher and editor-in-chief of CADCAMNet and Engineering Automation Report, the former senior editor of CADalyst magazine, and the author of more than a dozen books on AutoCAD. A licensed architect, David was also one of the earliest AutoCAD third-party software developers, creating numerous AutoCAD add-on programs. As an industry consultant, David has worked with many companies including Autodesk. He teaches college-level AutoCAD courses and is always a popular presenter at Autodesk University.

david@dscohn.com
Introduction

In the past, if you wanted to extract attribute data and use it to create a parts list, bill of materials, or schedule in AutoCAD, you had to extract the data to an external file or a spreadsheet, and then import it back into AutoCAD. And if you wanted to incorporate data from a spreadsheet in an AutoCAD drawing, you had to insert it using Windows’ Object Linking and Embedding (OLE). But these methods are no longer necessary thanks to several significant changes.

Beginning with AutoCAD 2005, you could create tables in AutoCAD. AutoCAD 2006 added to that capability by enabling you to extract data directly to a table that you could then place in your drawing. If you subsequently updated the attribute data contained in that table, AutoCAD could automatically update the table to reflect those changes. But this data attribute extraction table had several limitations, the most notable being that any modifications made to the table after it was created (such as adding columns or rows and performing calculations) would be lost if you ever modified any of the attribute data on which the table was based.

But starting in AutoCAD 2008, tables work differently. Significant enhancements include:

- Table data can be linked to data in Microsoft Excel and can include links to entire spreadsheets, single cells, or ranges of cells.
- Data links can be updated in both directions. If changes are made to the spreadsheet, those changes can quickly be applied to the table. If you make changes to the table, those changes can be applied to the spreadsheet.
- The tools for creating and managing table styles have been significantly changed and enhanced.
- New tools enable you to automatically fill data in the cells of a table.
- Tables can be broken into multiple fragments and the title and header can be repeated for each fragment.
- New number and currency formatting within rows, columns, and individual cells is available.
- You can extract property data from objects in drawings (including blocks and attributes) as well as basic drawing information. The extracted data can be linked to information in an Excel spreadsheet and output to a table or an external file.
- Information from an Excel spreadsheet can be added as columns with the data that has been extracted from a drawing.

Table Basics

Before we look at these various ways of creating and using tables, you should understand how tables work in AutoCAD. And even if you have used tables in previous versions of AutoCAD, you will find that tables have changed significantly.

A table consists of data organized in a grid format consisting of a number of rows and columns, similar to a spreadsheet. In addition, a table can optionally include a first row that displays the title of the table and a second row that displays column headings. (The title row could also be the last row and the headings row the second-to-last row; more on that later.)

Modifying Tables

After a table has been created, you can click any gridline on the table to select it. When selected in this fashion, the table displays column and row labels similar to a spreadsheet as well as grips that can be used to modify the table. When you hover over one of these grips, a tooltip displays showing you the grip function. You can also modify the table using the Properties palette or by right-clicking and using the shortcut menu.
Keep It Inside AutoCAD®: Data Extraction Direct to AutoCAD Tables

**NOTE:** When dragging to change the width of a column, hold down the CTRL key to change the column width and stretch the entire table; otherwise, just the single column changes. This is different from versions prior to AutoCAD 2008.

Tables can be broken into multiple fragments. To break a table, you must first enable table breaking in the Properties palette. You can then control the direction of the break, the height of each table fragment, and the spacing and position of each fragment. You can also repeat the title and header within each fragment.

You can click inside a cell to select it. When selected, column and row labels appear with the selected row(s) and column(s) highlighted. Grips are displayed in the middle of the cell borders, a special "AutoFill" grip is displayed in the lower-right corner of the cell, and the Table ribbon tab appears.
You can click inside another cell to move the selection to that cell. To select more than one cell, click and drag over several cells. You can also hold down the SHIFT key and click inside another cell to select those two cells and all the cells between them. With cells selected, you can modify the cells using the Properties palette or right-click and use the options on the shortcut menu. You can also drag the grips on a cell to make the cell and its column or row larger or smaller.

**NOTE:** When dragging to change the width or height of a cell, the overall size of the table also changes. Holding down the CTRL key no longer has an effect on this type of change.

**AutoFill**

The AutoFill function lets you automatically fill data in adjacent cells. You can simply copy data into the adjacent cells, copy formulas, or automatically increment data. For example, a table with a date column can have the dates automatically entered by filling in the first necessary date and then dragging the AutoFill grip. If one cell is selected and dragged, the numbers will fill automatically by increments of 1. Similarly, dates will resolve by increments of one day if only one cell is selected. If two cells are manually filled with dates one week apart, the remaining cells are incremented by one week.
You can also change the AutoFill options by right-clicking in the AutoFill grip and then selecting one of the options in the shortcut menu.

**Table Styles**

The appearance of the table is controlled by its table style, similar to the way a text style controls the appearance of text. You can use the default STANDARD table style or create your own table styles.

The tools for creating and modifying table styles have changed significantly since versions prior to AutoCAD 2008. When you create a new table style, you can specify a starting table. A starting table is a table in your drawing that is used as an example for formatting the new table style. Once a table is selected, you can specify the structure and contents to copy from that table to the new table style.

In addition to table styles, cell styles can now be created and applied to a table style upon insertion of a new table. A table style can specify different cell styles in each type of row to display a different justification and appearance for the text and gridlines. For example, the STANDARD table style contains a cell style consisting of merged cells with text that is centered. This cell style, named Title, can be specified as the first row cell of the table. This creates a title row at the top of the new table.

The table can read from top to bottom (down) or from bottom to top (up).

The border properties in a table’s cell style control the display of the gridlines that divide the table into cells. The borders of the title row, the column heads row, and the data rows can have different lineweight and color and can be displayed or not displayed. The Cell Style preview image in the bottom right corner of the Table Style dialog box updates as you select border options.

The appearance of text in the cells of the table is controlled by the text style that is specified in the current cell style. You can use any text style in the drawing or create a new one. You can also use DesignCenter to copy table styles from other drawings.

You can define the data and formatting for any cell style within a table style. You can also override the data and formatting for specific cells. For example, you could set the formatting for all column heading rows to display text in uppercase, and then select a single table cell to display text in lowercase. The type of data you display in a row and the formatting for that data type is controlled by the formatting options you select in the Table Cell Format dialog box.

Table styles are controlled using the Table Style dialog box.
The dialog box displays a list of all of the table styles available in the current drawing. You can select one of the available styles, create a new style, modify a selected style, or delete a style. Note that you cannot delete the STANDARD table style.

To create a new table style, click the New button. AutoCAD displays the Create New Table Style dialog box, in which you can specify the name for the new table style and select an existing table style on which the new style will be based.

After you have named the new table style, click the Continue button to display the New Table Style dialog box. (When modifying an existing table style, AutoCAD displays the Modify Table Style dialog box, which is identical to the New Table Style dialog box.) The controls within this dialog box are considerably different from versions prior to AutoCAD 2008.

1. Allows you to specify a table in your drawing to use as an example for formatting this table. Once you select a table, you can specify the structure and contents you want copied from that table.
2. Sets the direction of the table (down or up).
3. Displays available cell styles.
4. Launches the Create New Cell Style dialog box.
5. Launches the Manage Cell Styles dialog box.
6. Displays a preview of the effects of the current table style settings.
7. Displays a preview of the effects of the current cell style settings.
8. Select the tab to control the appearance of General settings, Text, or Borders.
General tab

9. Specifies the background color of the cell. The default is None.
10. Sets the justification and alignment for text in the table cell.
11. Sets the data type and formatting. Clicking this button displays the Table Cell Format dialog box.
12. Specifies the cell style as either a label or data.
13. Sets the distance between the text or block in the cell and the left and right cell borders.
14. Sets the distance between the text or block in the cell and the top and bottom cell borders.
15. Merges any new row or column created with the current cell style into one cell.

Text tab

16. Lists all the text styles in the drawing.
17. Displays the Text Style dialog box.
18. Sets the text height.
19. Sets the text color.
20. Sets the text angle.

Borders tab

21. Sets linewidth to be applied to the borders you specify.
22. Sets the linetype to be applied to the borders you specify
23. Sets the color to be applied to the borders you specify.
24. Displays the table borders a double lines.
25. Determines the spacing for double line borders.
26. Controls the appearance of the borders of the cells.

27. Apply to all borders
28. Apply to outside borders
29. Apply to inside borders
30. Apply to bottom border
31. Apply to left border
32. Apply to top border
33. Apply to right border
34. Don’t display any borders
Keep It Inside AutoCAD®: Data Extraction Direct to AutoCAD Tables

Extracting Data Using the Data Extraction Wizard

The Data Extraction wizard lets you extract attribute and other property data from selected objects directly to a table and/or an external file. This wizard takes the place of the Attribute Extraction wizard found in versions prior to AutoCAD 2008. The new wizard takes you through the process of:

- Selecting the data source, which can be a drawing, a set of drawings, or folders.
- Filtering objects (blocks and non-blocks) to be extracted and selecting properties from which data is extracted.
- Organizing and refining the extracted data.
- Merging information from an Excel spreadsheet with the extracted data.
- Choosing the output format for the data (a table and/or an external file).
- Formatting the extracted data in a table, by specifying a table style or selecting an existing pre-formatted table.

The first time you extract data, you are prompted to save the data extraction settings in a data extraction (DXE) file. Later, if you need to edit the data extraction, you select the DXE file, which contains all the settings (data source, selected objects and their properties, output format, and table style) that you used to create the extraction. For example, if you wanted to remove some property data from the extraction, you would select the DXE file that was used to create the extraction and make the desired changes.

A data extraction file can also be used as a template to perform the same type of extraction in a different drawing. The DXE file stores drawing and folder selections, object and property selections, and formatting choices. If you need to extract the same type of information repeatedly, using a DXE file can save considerable time.

You can also edit a DXE file. You can add or remove drawings, add or remove objects, or select different properties from which to extract data. Tables that reference the same DXE file, even if those tables are in other drawings, display the changes when those tables are updated.

**NOTE:** You can use an attribute extraction (BLK) file as a template for extracting data from blocks and attributes. When using a BLK file for extracting data or editing an existing extraction, you are prompted to save the data extraction to a DXE file in order to proceed with the extraction.

The Data Extraction wizard steps you through eight steps to extract the appropriate data and complete the table:

1. Select whether to create a new data extraction, use previously saved settings from a template, or edit an existing extraction.

   Depending on what you select, you will have to select the existing template and/or save the new template. If this is your first table, simply create a new data extraction. If you’ve already created a similar table, you may have saved a data extraction file that you can reuse, saving you some steps.
2. Select the data source.

You can extract properties (including attributes) from selected objects in a drawing, and all objects in a single drawing, multiple drawings, or folders.

Click the Add Folder button to add folders. Click the Add Drawing button to add additional drawings.

3. Select the objects to extract data from.

You can select objects, including blocks and their attributes, as well as other drawing property information.

Use the check boxes to filter objects. You can right-click to display a shortcut menu to aid in selecting objects.

4. Select the properties that you want to include.

Use the list on the right to limit the types of properties displayed on the left. Then select those properties you want to include in the data extraction. You can right-click in either list to display a shortcut menu to aid in selecting properties.
5. Refine the way the data will be included in the data extraction.

You can modify the data in many ways:
• Reorder, rename, hide, and sort data in columns
• Format data in cells
• Insert a formula column or insert a totals footer
• Filter data in columns
• Display or hide the Count or Name columns
• Group identical rows or display them individually
• Preview the table in a separate window
• Create a data link to an Excel spreadsheet

6. Select the output types for the extraction:
• Insert the data extraction into the drawing as a table
• Output the data to an external file

7. Select the table style to use for the inserted table.

You can select an existing table style from the drop-down list or define a new table style on the fly. You can also enter a title for your table and manually select the cell styles to be used for the Title, Header, and Data cells.

This step is skipped if not creating a table.
8. Click Finish to extract the data.

If you are inserting the data extraction as a table, AutoCAD will prompt you to specify an insertion point for the resulting table. Simply click to place the table in the drawing.

If you are extracting data to an external file, the file will be created automatically without any additional user intervention.

<table>
<thead>
<tr>
<th>SYM.</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>STYLE</th>
<th>MANUFACTURER</th>
<th>REF#</th>
<th>Quantity</th>
<th>COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3’</td>
<td>6'-9&quot;</td>
<td>TWO PANEL</td>
<td>TRU STYLE</td>
<td>TS 3010</td>
<td>2</td>
<td>189.00</td>
</tr>
<tr>
<td>2</td>
<td>3’</td>
<td>6'-9&quot;</td>
<td>TWO PANEL</td>
<td>TRU STYLE</td>
<td>TS 3010</td>
<td>7</td>
<td>189.00</td>
</tr>
<tr>
<td>3</td>
<td>5’</td>
<td>6'-8&quot;</td>
<td>FRENCH DOORS</td>
<td>TRU STYLE</td>
<td>FL 301</td>
<td>1</td>
<td>310.00</td>
</tr>
<tr>
<td>4</td>
<td>5’</td>
<td>6'-3&quot;</td>
<td>FRENCH DOORS</td>
<td>TRU STYLE</td>
<td>FL 1000</td>
<td>1</td>
<td>329.00</td>
</tr>
<tr>
<td>5</td>
<td>2'-4&quot;</td>
<td>6'-9&quot;</td>
<td>ONE PANEL</td>
<td>TRU STYLE</td>
<td>TS 3010</td>
<td>1</td>
<td>189.00</td>
</tr>
<tr>
<td>6</td>
<td>5’</td>
<td>6'-3&quot;</td>
<td>BI-FOLD</td>
<td>TRU STYLE</td>
<td>BF 5062</td>
<td>4</td>
<td>119.00</td>
</tr>
</tbody>
</table>

**Performing Calculations in AutoCAD Tables**

In AutoCAD, tables behave much like Excel spreadsheets. You can perform calculations on data directly in tables, rather than having to use external applications to handle data. For example, you could add a column that calculates the total cost of each type of door, and a row at the bottom that calculates the total cost of all doors. To add a column, select a cell in the table and then either click the Insert Column button in the Table toolbar or right-click and use the shortcut menu. You can use the same method to add rows.

**Table and Cell Locking and Linked Data**

Tables created using the Data Extraction wizard are initially locked. Although you can add columns and rows to a table, you cannot add anything to a cell while the cell is locked. You can unlock individual cells or the entire table.

Locked cells are indicated by a Lock cursor icon and tooltip that appears whenever you hover over a locked cell. You can unlock individual cells, groups of cells, or the entire table using the Table toolbar, the shortcut menu, or the Properties palette.
Cells in a table that contain data linked from a data extraction or linked Excel spreadsheet display indicators around linked cells. If you hover your mouse cursor over the data link, AutoCAD displays a Link cursor icon and a tooltip containing information about the data link.

**Using Formulas in Table Cells**

Table cells can contain formulas that do calculations using the values in other table cells. With a table cell selected, you can insert formulas from the shortcut menu. You can also open the In-Place Text Editor and enter a formula in a table cell manually.

In formulas, cells are referred to by their column letter and row number. For example, the cell at top left in the table is A1. Merged cells use the number of what would be the top-left cell. A range of cells is defined by the first and last cells, with a colon between them. For example, the range A5:C10 includes cells in rows 5 through 10 in columns A, B, and C.

A formula must start with an equal sign (=). The formulas for sum, average, and count ignore empty cells and cells that do not resolve to a numeric value. Other formulas display an error (#) if any cell in the arithmetic expression is empty or contains nonnumeric data.

Use the Cell option on the shortcut menu to select a cell in another table in the same drawing. When you have selected the cell, the In-Place Text Editor opens so you can enter the rest of the formula.

For example, let’s insert a column and perform some calculations on the data in the table:

1. Select a cell in the right-most column (column H).
2. Right-click and select Columns > Insert Right from the shortcut menu.
3. Click the column I header to select the entire column.
4. Right-click any of the square grips in column I and choose Locking > Unlocked from the shortcut menu.
5. Select the cell in the Header row of the new column, type **TOTAL**, and press ENTER. The cursor moves to the next cell in the new column.
6. Type **=G3*H3**, and then click the Close Text Editor button on the Multiline Text ribbon tab to close the Text Formatting dialog box.

You could repeat these steps to add formulas to the new column for the other doors, but it is much faster to simply copy the formula you just added.

**Copying a Formula**

When you copy a formula to another cell in the table, the range changes to reflect the new location. For example, if the formula in I3 equals the product of cells G3 and H3, when you copy it to I4, the range of cells changes so that it equals the product of cells G4 and H4.
But it's even easier to use the AutoFill capability. To copy the formula to the remaining rows:

1. Select cell I3.
2. Move your cursor to the bottom-right corner of the cell, place your cursor in the exact center of the grip, and click the grip.
3. Right-click the AutoFill grip and choose Fill Series from the shortcut menu.
4. Drag the AutoFill grip to cell I8 to copy the formula to the remaining five rows.

**NOTE:** If you don’t want a cell address to change when you copy and paste the formula, add a dollar sign ($) to the column or row portion of the address. For example, if you enter $A10, the column stays the same and the row changes. If you enter $A$10, both column and row stay the same.

### Adding Up the Sum of the Values

Next, you can insert a row at the bottom of the table and create a new formula to calculate the sum of all of the costs.

1. Select a cell in the bottom row (row 8), right-click, and choose Rows > Insert Below.
2. Click the row 9 label to select the entire row, right-click, and unlock the row.

**NOTE:** If you had unlocked the entire table instead of just the column that was added, any rows or columns you subsequently add will be unlocked.

3. Select cells A9 through H9, right-click, and choose Merge > All from the shortcut menu.
4. Select the merged cell you just created and then type **TOTAL COST OF DOORS**.
5. On the Multiline Text ribbon tab, change the Justification to Middle Right, and then click Close Text Editor.
6. Select cell I9, right-click, and choose Insert > Formula > Sum from the shortcut menu.
7. When AutoCAD prompts you to Select first corner of table cell range:, click inside cell I3.
8. When AutoCAD prompts you to Select second corner of table cell range:, click inside cell I8.
9. Verify that the formula in cell I9 reads =Sum(I3:I8). When satisfied, click Close Text Editor.

### Updating the Table

In versions prior to AutoCAD 2008, if the attribute data in the drawing changed, AutoCAD would display a notification balloon telling you that the table needs updating, and you could update the table by simply clicking on a link in the balloon. But, if you had made any modifications to the table (such as adding rows and columns and performing calculations), all of those modifications...
would be deleted when the table was updated. AutoCAD no longer alerts you when the attribute data changes; you will need to manually force the table to update. But manual modifications are no longer deleted when you update the table.

**NOTE:** AutoCAD will alert you if you have linked an Excel spreadsheet and the spreadsheet data subsequently changes.

**WARNING:** The DXEVAL system variable can be set so that data extraction tables update automatically under certain circumstances. But if you use this method, some of the modifications you manually make to tables will be lost.

To force tables to update after data has been changed, do one of the following:
- Select the table, right-click, and choose Update Table Data Links from the shortcut menu.
- Right-click the Data Link button on the Status Bar, and choose Update All Data Links.
- Click the Download from Source button on the Linking & Extraction panel on the Block & References ribbon tab.

## Data Linking

You can also create AutoCAD table cells that link to an Excel spreadsheet. One easy way to do this is to copy the data from Excel, and then using Paste Special, paste the data into the AutoCAD drawing as a link. This pastes the Excel data into AutoCAD as a Table object. AutoCAD automatically creates a data link between the drawing and the Excel spreadsheet.

If changes are made to the data in the external file, AutoCAD displays a balloon notifying you of the changes. You can then quickly update the table by clicking on the link inside the balloon.

To copy data from Excel and create a table in AutoCAD:
1. Open the spreadsheet in Excel.
2. Select the cells you want to link, and copy them to the clipboard.
3. In AutoCAD, select Edit > Paste Special.
4. In the Paste Special dialog box, choose Paste Link, select AutoCAD Entities, and then click OK.
5. When AutoCAD prompts you to Specify insertion point:, click in the drawing to insert the table.

If you modify any of the data in the Excel spreadsheet and save your changes, AutoCAD soon displays the notification balloon.

When you copy and paste Excel data into AutoCAD using this method, AutoCAD creates a generic name for the data link. You can display the Data Link Manager dialog box, however, and give the link a more meaningful name.
To display the Data Link Manager, do one of the following:
- On the Blocks & References ribbon tab, click the Data Link button.
- From the Menu Browser, choose Tools > Data Links > Data Link Manager.
- Right-click the Data Link button on the Status Bar and choose Data Links.
- At the command line, type `DATALINK` and then press ENTER.

To rename a data link, right-click the data link in the Data Link Manager, choose Rename from the shortcut menu, and then enter the desired data link name.

In the Data Link Manager dialog box, if you right-click on a data link and choose Edit in the shortcut menu, AutoCAD displays the Modify Excel Link dialog box. This dialog box lets you specify whether you want to link the whole spreadsheet or a specific range of cells. You can also specify whether you want to allow changes to the cell contents in the AutoCAD table to be able to be written back to the Excel spreadsheet.

**NOTE:** If you don’t see the entire dialog box, click the arrow button in the lower-right corner to expand the dialog box.

Remember that when AutoCAD creates a table, its linked cells are initially locked. So, even after modifying the data link so that you can write data back to the spreadsheet, you won’t be able to modify any of the data in the table until you unlock the cells.

After unlocking the cells, if the ability to allow writing to source file has been enabled, you can easily write the changes you make to the AutoCAD table back to the source data file.

To write the changes back to the source data file, do one of the following:
- From the Menu browser, choose Tools > Data Links > Write Data Links; when prompted to Select objects:, select the table, and then press ENTER.
- Click the Upload to Source button on the Linking & Extraction panel on the Block & References ribbon tab.
- Select the table, right-click, and choose Write Data Links to External Source from the shortcut menu.
Combining Extracted and Linked Data

You can also create a table that combines data extracted from properties in an AutoCAD drawing with data in an Excel spreadsheet. For example, suppose you had a spreadsheet containing pricing information and an AutoCAD drawing from which you could derive quantities. You can create a table that links the quantity takeoff and cost data.

In addition to the data link AutoCAD creates automatically when you use the Paste Special command to insert Excel data as a table, you can create data links manually.

In this example, the various utilities (gas, water, sewer, etc.) for a large building site are each drawn on their own layer. Using the Data Extraction wizard, you can create a table that extracts those pipe lengths and then combines them with cost data maintained in an Excel spreadsheet.

To create a link to cost data stored in an Excel spreadsheet:
1. Open the drawing in which you want to create the table.
2. From the tools menu, choose Data Links > Data Link Manager.
3. In the Data Link Manager dialog box, under Excel links, click Create a New Data Link.
4. In the Enter Data Link Name dialog box, enter the name you want to use to identify the data link (such as cost_data) and click OK.
5. In the New Excel Data Link dialog box, click the Browse button, navigate to the folder containing the spreadsheet you want to link (in this case, cost_estimate.xls), and click Open.
6. Ensure that the Link Entire Sheet option is selected, then click OK.
7. Verify that cost_data is selected in the Data Link Manager dialog box, then click OK.
8. Save your drawing. You have just created and saved a dynamic link to the cost estimate spreadsheet.

Now you’re ready to create the table containing the extracted piping system data.

Create a cost estimate table using the Data Extraction wizard:
1. Start the Data Extraction wizard.
2. In the Begin (Page 1 of 8) page, ensure that the Create a New Data Extraction option is selected, then click Next.
3. In the Save Data Extraction As dialog box, navigate to the folder in which you want to create the extraction file, enter the DXE file name (such as cost_est), and click Save.
4. In the Define Data Source (Page 2 of 8) page, specify the drawing file from which the data is to be extracted. (Note that in this example, the data is actually coming from an external reference, so you need to clear the Include Current Drawing check box, click the Add Drawings button, and select the external reference drawing.) Then click Next.

5. In the Select Objects (Page 3 of 8) page, right-click and choose Uncheck All from the shortcut menu, then select the Arc, Line, and Polyline check boxes.

6. Under Display Name, right-click Arc, choose Edit Display Name from the shortcut menu, and enter Pipes as the display name. (You can also simply click in the display name cell and then type.)

![Data Extraction - Select Objects (Page 3 of 8)](image)

**NOTE:** The Data Extraction wizard uses the display names to reconcile the records (rows) when you combine record modes. The Data Extraction wizard is case-sensitive.

7. Repeat Step 6, changing the display name for both Line and Polyline to Pipes also. Then click Next.

8. In the Select Properties (Page 4 of 8) page, right-click in the Properties pane and choose Uncheck All from the shortcut menu. Scroll down and select the Layer and Length check boxes. Then click Next. (Note that if AutoCAD displays an alert box informing you that non-uniformly scaled blocks cannot be extracted, click OK. Numerical values from non-uniformly scaled blocks may not be correct or useful and must therefore be ignored.)

9. In the Refine Data (Page 5 of 8) page, make sure that the Combine Identical Rows and Show Name Column check boxes are selected and the Show Count Column check box is not selected.

10. Click the Link External Data button.

11. In the Link External Data dialog box, select cost_data in the Data Link drop-down.


13. Click the Check Match button. AutoCAD displays a dialog box verifying that the key pairing was successful. Click OK to close the Valid Key dialog box.
14. In the Additional Columns for Data Table pane, clear the Piping Systems check box. Then click OK to return to the Refine Data (Page 5 of 8) page.

15. Right-click the Cost column and choose Insert Formula Column from the shortcut menu.

16. In the Insert Formula Column dialog box, enter **Sum** as the column name. Then create the formula **Cost * Length** by doing the following:
   1) Double-click Cost in the Columns pane.
   2) Click the * button.
   3) Double-click Length in the Columns pane.

   Then click the Validate button to ensure that the formula is valid. Click OK to close the Valid Equation dialog box. Then click OK to return to the Refine Data (Page 5 of 8) page.

   ![Image of Insert Formula Column dialog box]

   The Sum column now displays the $\int$ icon, denoting a formula column.

17. Right-click the Length column and choose Combine Record Mode > Sum Values from the shortcut menu. This action groups similar layer values based on the Display Name, and lists the sum of the columns selected. So rather than seeing the length for every pipe on every layer, AutoCAD sums the lengths of the pipes on each layer.

18. Right-click the Sum column and choose Insert Totals Footer > Sum from the shortcut menu. Then click Next.

19. In the Choose Output (Page 6 of 8) page, select Insert Data Extraction Table Into Drawing check box, and then click Next.
20. In the Table Style (Page 7 of 8) page, select an existing table style (or define a new one using the methods previously described). Enter a title for your table (such as **Cost Estimate**). Then click Next.

21. In the Finish (Page 8 of 8) page, click Finish and then position the table in the drawing.

If you subsequently modify any of the pricing information in the Excel spreadsheet, AutoCAD will alert you via the balloon notification, and you can quickly update the table to reflect those changes. (Note that if AutoCAD doesn’t alert you of the change, you can update the table manually by updating the data links.)

If you modify the arcs, lines, or polylines in the drawing from which you extracted the properties, you can update the table to reflect those changes by updating the data links.

Note that this example exercise, including data files, can be downloaded from the Autodesk website.

**Conclusions**

AutoCAD brings incredible new power to AutoCAD tables. Users can now do things that they’ve only dreamed of being able to do in AutoCAD for more than 20 years.

Tables are considerably different than they were in versions prior to AutoCAD 2008. At last, linking data no longer requires programming—anyone can do it—making the power of tables and data links available to all AutoCAD users.

<table>
<thead>
<tr>
<th>Name</th>
<th>Layer</th>
<th>Length</th>
<th>Cost</th>
<th>Sum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pipes Gas Lines</td>
<td></td>
<td>2758.0747</td>
<td>450</td>
<td>1241133.5938</td>
</tr>
<tr>
<td>Pipes Sewer Line</td>
<td></td>
<td>2082.2543</td>
<td>700</td>
<td>1457678.0199</td>
</tr>
<tr>
<td>Pipes Sewer Line - Force Main</td>
<td></td>
<td>952.0567</td>
<td>1200</td>
<td>1142470.4977</td>
</tr>
<tr>
<td>Pipes Water Line</td>
<td></td>
<td>8257.5973</td>
<td>650</td>
<td>4007430.2267</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>7908820.3381</td>
</tr>
</tbody>
</table>